PHP 5.6+ required.